Monday, 4 March 2013

Simmon refurb part 2

 Quick update on the Simmons refurbishment. I was struggling to find a replacement potentiometer with the correct footprint, so I decided to put a random one that was lying around as a temporary fix, and to see how many issues it resolved.



This involved a small amount of ninja soldering work. The legs of the pot were not the "through hole" type, so I had to add extra small wires to bridge the connection. I then put the unit back together (thankfully I had taken heaps of photos of taking it apart), and turned it on. Huzza, I now have a clean, working mix output!

 
Check out the sweet big knob I found at work.

After further experimentation, and uh, *cough* reading of the manual I've worked out that the unit is pretty much working 100% properly. I initially thought there was something wrong with the "Sequencer In" input, but it turns out it is not MIDI, but some weird proprietary system Simmons used in 1980-something. No wonder the unit goes berserk when I connect MIDI devices to that socket.

In the end I bought a proper replacement potentiometer from Small Bear Electronics... It's apparently in the post.

In other news I've ordered a bunch of drum hardware for my novelty clear drumkit... Updates coming soon.

2 comments:

  1. did you use .24mm terminals like these:?
    http://smallbear-electronics.mybigcommerce.com/pot-alpha-100k-linear-and-audio-usa-big-muff/

    I have an SDS9 that needs 10 new pots :(

    ReplyDelete
    Replies
    1. Hey there, sorry for the late reply! Having now upgraded that thing, I can pretty confidently say the pots I bought didn't fit that well. I reckon have a look at the ones in the Yocto 808 (http://www.e-licktronic.com/), I think they'd fit better.

      http://www.e-licktronic.com/

      Delete